hacked:install_a

NEW: Stats & Info for your O!Play… oplaywarenfoo.cgi 19/02/2010 12:03:10

install_a

ELF 32-bit LSB executable, MIPS, MIPS32 rel2 version 1 (SYSV), statically linked, stripped

A completely 'rough' & ready approach I simply examined the file in the Oketa Hex Editor. There appears to be a whole lot of information in the file that #may# be encrypted (or at least obfuscated)… Most of this information is related to the install procedure and is passed to the ROM Monitor which is accessed via the serial port.

Plz don't turn off the power!

Plz don't turn off the power!...Start Installation...(rev:%s)...282843
Install Completed !.Install Error ! Please Reboot Again.
Please do not turn off the power!...
Install Error! Please Reboot!...
AVHDD Verona installer (src rev: %s)......
%s %s.....Nov 26 2009.20:07:23

/usr/local/resource

/.../usr/local/Resource./usr/local/etc..
ERROR: open %s failed!..-xf.-axf....| 
unlzma..../dev/mtd/%s.%s../dev/mtd/0..
ERROR: open %s error.(%s)...
Open %s error!..ERROR: get meminfo 
from %s error.(%s)...
Get meminfo from %s error!..dd if=%s 
bs=%lu skip=%lu | tar %s - video_firmware.install.bin 
arial.ttf..../dev/mtdblock/0.wget -O - %s | tar %s - 
video_firmware.install.bin arial.ttf....tar %s %s 
video_firmware.install.bin arial.ttf..Fail to execute 
command, %s!....[time] t=%03llu.%03llu..
video_firmware.install.bin..arial.ttf...Can not find 
video_firmware.install.bin or arial.ttf from %s!..../..
Load A/V images failed!.rm -f video_firmware.install.bin....
Fail to execute command, %s!....
ERROR: lseek to %u error.(%s)...
ERROR: write error!(%s).....
ERROR: read error!(%s)

Errors XML

Error! XML syntax version not support!(ver: %s)..
Version not match!..%s/%s...tar xvf %s -C %s %s.
Can not execute command, %s!....Can not stat %s!
....get_checksum_from_fd....%s: lseek to %llu error! 
(%s)...%s: read from fd error!(%s).....ERROR: error open %s.
(%s)...lseek %s to 0x%x error!.ERROR: error write image, %s, to flash.
(%s).....Write %s error!.lseek flash to 0x%x error!..
ERROR: error read image, %s, to buffer.(%s).....Read %s error!..image...
Can not find image description, %s, from flash target

Got NAND Flash device

>>>>>> Got NAND Flash device! Start installation........
>>>>>> Got NOR Flash device! Start installation..

chip_id = %x S_CHIP(MARS)

video_firmware.bin..chip_id = %x....
SB2 DEBUG CONTROL(%d)= 0x%x ....--> 
0x%x....SB2 INT = 0x%x .SB2 start addr
(%d)= 0x%x ...SB2 end addr(%d)= 0x%x .
IS_CHIP(MARS)...Mars.........Cannot find 
%s/%s!......Cannot open %s/%s!...... 
got %s/%s.....video start addr, ptr=%p....
video image size, cnt=%d.....audio_addr = 
0x%x...video_addr = 0x%x... 
sleep for 3 seconds........
Calling pli_resetRPC()......Release HW Semaphore...
/sys/realtek_boards/system_parameters

Mail test reports to David

function sendMail(obj){.window.location.href = 
"mailto:david<david@rxxxxxk.com>?subject=HDMI Test Report&body=

Lots of UNIT TESTING

Wait for unit ready.....:-( unable to TEST UNIT READY...REQUEST SENSE...[TEST UNIT READY]

experiment & investigate a custom firmware for the Asus O!Play HD Digital Media Streamer

USE ENTIRELY AT YOUR OWN RISK. Use of the OPlayWare website is subject to published Disclaimer and Privacy Policy

Unless otherwise stated, the content of this page is licensed under Creative Commons Attribution-ShareAlike 3.0 License